当前位置: 首页 >汽车>正文

飞狐股票公式:无忧箱体

来源:时间:2019/8/3 14:30:00

飞狐股票公式是什么?飞狐股票公式有哪些?下面为您介绍飞狐股票公式。

DRAWGBK(c》0,COLORRGB(17,5,0),COLORRGB(0,0,0),1);

STICKLINE(C》O ,H,L,0.1,0),COLORRED;

STICKLINE(C》O ,C,O,8.5,1),COLORRED;

STICKLINE(C《=O ,H,L,0.1,0),COLORCYAN;

STICKLINE(C《=O ,C,O,8.5,1),COLORCYAN;

CURRBARSCOUNT:=DATACOUNT-BARPOS+1;

拉升:IF(CURRBARSCOUNT=1 AND REF(C,1)REF(C,1) ,REFX(REF(C,1)*1.01,DATE),0),COLORFF00FF,LINETHICK0;//AND MA1》REF(MA1,1) CONST DRAWNULL

A001:STICKLINE(CURRBARSCOUNT=1 AND C》=REF(C,1),拉升,拉升*0.9992,15,0),COLORMAGENTA;

DRAWTEXT(CURRBARSCOUNT=1 AND 拉升=REFX(REF(C,1)*1.01,DATE),L*0.99996,‘ 拉升线’),COLORMAGENTA;

止损:REF(HHV(H,13),1)*0.95,COLORGREEN,LINEDOT;

A002:STICKLINE(CURRBARSCOUNT=1 AND C》=REF(C,1),止损,止损*0.9996,15,0),COLORGREEN;

DRAWTEXT(CURRBARSCOUNT=1,止损*0.996,‘止损线’),COLORGREEN;

AB:=EMA(((2*C+H+L)/4-LLV(LOW,30))/

(HHV(HIGH,30)-LLV(LOW,30))*100,8);

BA:=EMA(AB,5);

A1{高}:=REFX(REF(HHV(H,96),5),DATE);

B1{低}:=REFX(REF(LLV(L,96),5),DATE);

D{中}:=((A1)+(B1))/2;

五:MA(C,5)LINETHICK2,COLOR00FFFF;

二O:EMA(C,20),COLORMAGENTA;

空仓:PARTLINE(AB-BA《0,五),LINETHICK2,COLOR00FFFF;

持仓:PARTLINE(AB-BA》0,五),,LINETHICK2,COLORRED;

箱顶:IF(AB》0 AND AB-BA《=0,A1,A1),LINETHICK3,COLOR00FF00;

箱腰:IF(AB》0 AND AB-BA《=0,D,D),LINETHICK3,COLOR00FF00;

箱低:IF(AB》0 AND AB-BA《=0,B1,B1),LINETHICK3,COLOR00FF00;

_____五:PARTLINE(CURRBARSCOUNT=6,L*0.992-0.02),

CROSSDOT,COLORWHITE,LINETHICK3;{五日转点}

十:PARTLINE(CURRBARSCOUNT=11,L*0.992-0.02),

CROSSDOT,COLORYELLOW,LINETHICK3;{十日转点}

二十:PARTLINE(CURRBARSCOUNT=21,L*0.992-0.02),

CROSSDOT,COLORRED,LINETHICK3;{二十日转点};

三十:PARTLINE(CURRBARSCOUNT=31,L*0.992-0.02),

CROSSDOT,COLORCYAN,LINETHICK3;{三十日转点};

六十:PARTLINE(CURRBARSCOUNT=61,L*0.992-0.02),

CROSSDOT,COLORYELLOW,LINETHICK3;{六十日转点};

九十:PARTLINE(CURRBARSCOUNT=91,L*0.992-0.02),

CROSSDOT,COLORYELLOW,LINETHICK3;{九十日转点};

高1:PARTLINE(AB》0 AND AB-BA》0,A1),LINETHICK3,COLORRED;

中1:PARTLINE(AB》0 AND AB-BA》0,D),LINETHICK3,COLORRED;

低1:PARTLINE(AB》0 AND AB-BA》0,B1),LINETHICK3,COLORRED;

C2:=REF(C,1);

涨停:=IF((C-C2)*100/C2》=(10-0.01*100/C2),1,0);

STICKLINE(涨停,OPEN,CLOSE,2,0),COLORYELLOW;

STICKLINE(涨停,H,L,0,0),COLORRED;

跌停:=IF((C2-C)*100/C2》=(10-0.01*100/C2),1,0);

STICKLINE(跌停,OPEN,CLOSE,2,0),COLORGREEN;

STICKLINE(跌停,H,L,0,1),COLORGREEN;

{选股}

HHH:=CROSS(C,MA(L+(H-L)/2,25)*0.95);LLL:=CROSS(MA(L+(H-L)/2,25)*0.95,C);

CCC:=CROSS(H,MA(L+(H-L)/2,25)*1.15);DDD:=CROSS(H,MA(L+(H-L)/2,25)*1.25);

DRAWTEXT(HHH AND MA(L+(H-L)/2,75)》=REF(MA(L+(H-L)/2,75),1),L*0.98,‘买吧’),COLOR6699FF;

DRAWTEXT(CCC AND MA(L+(H-L)/2,75)》=REF(MA(L+(H-L)/2,75),1),H*1.02,‘卖了’),COLOR6699FF;

DRAWTEXT(DDD AND MA(L+(H-L)/2,75)》=REF(MA(L+(H-L)/2,75),1),H*1.02,‘小心顶’),COLOR6699FF;

VAR1:=(100 - ((90 * (HHV(HIGH,14) - CLOSE)) / (HHV(HIGH,14) - LLV(LOW,14))));

VAR2:=(100 - ((90 * (HHV(HIGH,14) - CLOSE)) / (HHV(HIGH,14) - LLV(LOW,14))));

VAR3:=(100 - MA(((100 * (HHV(HIGH,6) - CLOSE)) / (HHV(HIGH,6) - LLV(LOW,6))),34));

DIR1:=ABS(CLOSE-REF(CLOSE,5));

VIR1:=SUM(ABS(CLOSE-REF(CLOSE,1)),5);

ER1:=DIR1/VIR1;

CS1:=ER1*(0.8-2/8)+2/8;

CQ1:=CS1*CS1;

DIR2:=ABS(CLOSE-REF(CLOSE,10));

VIR2:=SUM(ABS(CLOSE-REF(CLOSE,1)),10);

ER2:=DIR2/VIR2;

CS2:=ER2*(0.8-2/24)+2/24;

CQ2:=CS2*CS2;

DRAWICON(CROSS(VAR2,MA(VAR3,6)),(LOW - (LOW*0.02)),8);

DRAWICON(CROSS(MA(VAR3,6),VAR1),(HIGH+(HIGH*0.02)),9);

PT:=REF(H,1)-REF(L,1);

CDP:=(REF(H,1)+REF(L,1)+REF(C,1)*2)/4;

AH:=CDP+PT;

AL:=CDP-PT;

NH:=CDP*2-REF(L,1);

NL:=CDP*2-REF(H,1);

强:IF(AH》REF(C,1)*1.1,REF(C,1)*1.1,AH),LINETHICK0;

阻:IF(NH》强,(强-CDP)*0.618+CDP,NH),COLORBLUE,LINETHICK0;

{ M:=IF(AL

撑:IF(NL

底:IF(AL

编辑五、六次,无法显示完整源码,无奈!}

{量能饱和度}

SAT:=(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20));

【量能饱和】:=IF(SAT》1,1,SAT)*100,COLORYELLOW,LINETHICK0;

{活跃度}

LC:=REF(CLOSE,1);

RSI5:=(SMA(MAX(CLOSE-LC,0),3,1))/(SMA(ABS(CLOSE-LC),3,1))*100;

WR10:=(HHV(HIGH,3)-CLOSE)/(HHV(HIGH,3)-LLV(LOW,3))*100;

活跃度:=(RSI5-WR10),COLORFFFF00,LINETHICK0;

活跃度比:=IF(活跃度》=0,(活跃度+100)/2,100-ABS((活跃度-100)/2));

M1:=30;

P2:=80;

VAR11:=(C+H+O+L)/4;

买入:=EMA(VAR11,M1)*(1-P2/1000),COLORFFFFFF,LINETHICK2;

反弹:=EMA(EMA(EMA(HIGH,5),5),5)*0.95,COLORRED,LINETHICK1;

XG:=CROSS(买入,反弹);

DRAWTEXT(XG,(LOW -0.2),‘暴’ ),COLORRED;

更多飞狐股票公式知识请关注

飞狐股票公式:无忧箱体

相关标签:
分享至:

评论 0条评论

期待你的神评论~
剩余200

全部评论(0

    还没有评论,快来抢沙发~

    点击加载更多

    删除操作

    确认删除此条评论?
    删除
    取消